Back to overview
Degraded
Background Check Degraded Service
May 7, 2026 at 1:40pm UTC
Affected services
Background Check Service
Resolved
May 7, 2026 at 3:21pm UTC
Moodys has resolved the issue.
The connectivity issues didn't affect our integration with RDC and no errors have been reported in our monitoring system.
Affected services
Created
May 7, 2026 at 1:40pm UTC
Moodys reported connectivity issues that might affect the access to the API. We are monitoring the situation and for now we are not seeing any errors.
We will keep you updated.
See details here: https://status.rdc.com/incidents/qr7g5ckzkfmy
Affected services