Back to overview
Degraded

Background Check Degraded Service

Mar 13, 2026 at 7:23am UTC
Affected services
Background Check Service

Resolved
Mar 13, 2026 at 8:06am UTC

Background check service has been fully restored. You can view the details here: https://status.rdc.com/.

Created
Mar 13, 2026 at 7:23am UTC

RDC has reported an issue that they are currently investigating. You can view the details here: https://status.rdc.com/.

Based on our logs, only a small subset of requests appears to be affected at this time. We will continue monitoring the situation and keep you updated.