Back to overview
Degraded

Service capacity issue in multiple regions

Oct 09 at 11:27am BST
Affected services
Authorization Service
Scan Service
Background Check Service
Face Match and Face Search Service
Face Liveness+Matching Service
Info Service
No-code KYC Frontend
No-code KYC Backend
No-code KYC Websocket
Customer Portal

Resolved
Oct 09 at 05:00pm BST

Microsoft Azure has reported that the issue has been mitigated. You can see the details here https://azure.status.microsoft/en-gb/status/history/.

Our monitoring confirms that latency has improved. We will continue to observe the situation over the coming hours.

Created
Oct 09 at 11:27am BST

Impact Statement: Starting at 07:40 UTC on 09 October 2025 our customers may experience intermittent issues when accessing their services.

The issue is associated with an Azure service. You can view the details at: https://status.azure.com/en-gb/status/