Back to overview
Degraded

Background Check Degraded Service

Jan 14 at 11:42am GMT
Affected services
Background Check Service

Resolved
Jan 14 at 07:42pm GMT

Background check service fully restored. See details here https://status.rdc.com/

Created
Jan 14 at 11:42am GMT

You can see the details here https://status.rdc.com/